Wordpress Plugins Can Drive You CrazyIf you have a WordPress blog, you know. Never update plugins!

WordPress is fantastic, and is without doubt the best blogging platform available. However, for those who have a self-hosted WordPress blog, you will know the pain of plugin updates, and how they can drive you crazy.

The problem is, that many plugins are written by part-time coders, and not all of them really know how to, or even bother with doing a pre-test of a new version of their plugin, other than to release it, and then try to solve all the problems from users that occur, and appear as screams on their support pages.

For free plugins, I can accept this. There is always the backup insurance of WP Rollback, so I can revert to the previous version in a few minutes.

But I have quite a few paid plugins, and quite honestly, I get very annoyed when I pay good money, only to get the same result when an update arrives, and it doesn’t work. Worse, when a a paid plugin update plays merry hell with my blogs. Today was one of those days.

Call it trust, but I updated a paid plugin, and whack! Errors, bugs, loss of function and a whole lot of pain. I hit the paid support forum, only to find a long list of other paying users complaining about the same issue. And all waiting for a response from our promised paid support.

Hello, is anyone home? Apparently not.

One big problem with paid plugins, is that it is impossible to use WP Rollback, as the previous versions are not listed in the WordPress repository. Why, who knows? But it does mean that paying for something does not necessarily mean that you get more. In fact, it seems that you get less.

So the lesson?

Never update a WordPress plugin until you check the support forums for each individual plugin. The problems will be listed there, by very angry users, like me.

Lastly, trust paid plugins even less, as there is no easy way back.

Yes, it’s been a bad WordPress day.

Tagged on:

2 thoughts on “WordPress Plugin Updates Can Drive You Crazy

  • 16/01/2016 at 7:57 am

    I’m pissed off that WordPress have got rid of the old blog post editor. The new one is a total pain in the backside! For one thing, the idiots forgot to include the spell check button in its tool bar – grrrrrrrrr :(

  • 28/04/2016 at 6:25 pm

    Actually, for security reasons you should *always* upgrade your plugins.

    Just make a backup of everything. Usually if some update breaks your site, just go on your FTP and rename the plugins folder to something else. If your site is back working, rename the folder again and then check for the latest updated plugins, those are the cause of breaking.


Add Your Comment

Your email address will not be published. Required fields are marked *


By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.